Access blocked for older browsers from 27 May 2018

Skip to main content.

Access blocked for older browsers from 27 May 2018

Our website hosting provider is changing a configuration to ensure that our websites and the data hosted on them stay secure. This change will block version 1.1 of the TLS protocol, which involves secure website browsing.

The list of browsers affected by this configuration change is available below. If you are using any of these browsers, you may do any of the following to ensure that you can continue to access our website:

  • Upgrade your browser to the latest version;
  • Change your browser to one that works with the new configuration;
  • Update your browser configuration to enable TLS 1.2.

For specific instructions on how to configure your browser, please visit the GeoTrust Support Pages.

The following affected browsers will need to have an upgrade or alternative browser installed:

Desktop

  • Internet Explorer 7 and below
  • Firefox 22 and below
  • Chrome 21 and below
  • Safari 6 and below for OS X 10.8 (Mountain Lion) and below

Mobile

  • Internet Explorer 10 and below
  • Android 4.3 (Jelly Bean) and below
  • Mobile Safari for iOS 4 and below
  • Chrome 21 and below

The following affected browsers can be configured to use TLS 1.2:

Desktop

  • Internet Explorer 8, 9 or 10
  • Firefox 23-26
  • Chrome 22-37

Mobile

  • Android 4.4 (KitKat) to 4.4.4
  • Chrome 22-37
Published on April 26, 2018